MEGA65 FORUM

build errors

append delete Gurce

Hi guys, just getting some build errors, probably just initial learning curve issues for me, but thought I'd try ping you here on them.

I tried pinging you on the IRC channel (EFNet #mega), but I had to go zzz, so perhaps I missed a response there (does IRC keep a backlog/history of past convos?).

Anyway, here was my Q copy/pasted from IRC:

------

[23:30] <gurce> I'm just getting my bearings with ISE Design Suite (Proj Navigator).
[23:32] <gurce> It sees two *.xise files: "c64accel.xise" and "mega65.xise". I'm guessing I need to open the latter?
[23:33] <gurce> when i do, it warns of missing "charrom.vhdl", "kickstart.vhdl" and "version.vhdl" files. I saw a git commit somewhere mentioning these were auto-generated?
[23:35] <gurce> So, I guess I need to do the build/synthesise step then. At a guess, I thought this was done via "Process >> Implement Top Module", but that gave me lots of vhdl errors inside "uart_monitor.vhdl". Anybody got any pointers on where I'm going wrong? :)

-----

Reply RSS

Replies

append delete #26. Ben-401

the design at:
https://github.com/Ben-401/c65gs/tree/dockit
is for building on Linux (not windows).
Refer to the build documentation at
https://github.com/Ben-401/c65gs/blob/dockit/doc/build.md
which describes how I build on Linux, which maybe useful for users with Cygwin/Windows.

Reply

(Leave this as-is, it’s a trap!)

There is no need to “register”, just enter the same name + password of your choice every time.

Pro tip: Use markup to add links, quotes and more.

Your friendly neighbourhood moderators: Deft, gardners, MARCOM